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ExpeData 
ExpeData allows the user to explore acquired data in a rich graphic environment where each parameter 

of the system has been recorded. All data is stored in raw form; therefore, all data analysis is retraceable 

and will stand up to peer review. Raw data storage also allows for future analyses to be performed on a 

previous experimental run, ensuring versatility of your data and experimental time.  

Opening and Reviewing Data Files 
1. Start ExpeData. 

2. Open a data file. Click on File → Open or Ctrl + O. Choose a file, and open it by double-clicking 

the file name or clicking Open. 

3. Review the test contained in the yellow box at the bottom left of the screen. The explanation for 

each test line is as follows: 

     

File Name 

Date and time at which the file ended 

Number of data channels in the file 

Actively displayed ‘Active’ channel 

Instrument for ‘Active’ channel data 

Number of data samples in the file 

Sampling interval & total file duration 

Number of markers & file status1 

 

4. View another data channel by making it the active data channel. Click ‘View’ → ‘Active 

Channel…’ or type Ctrl + A. Choose the data channel you want to view by scrolling through the 

list, selecting it and clicking ‘OK’, or by double-clicking on the channel’s name. 

5. Other data channels can be displayed using Step 4 or keyboard shortcuts. Ctrl + Shift +  or → 

can be used to navigate through the data channels with the same channel prefix. Ctrl +  or → 

can be used to navigate to the previous or next data channel, respectively. 

6. Zoom into the data recording to view it in more detail. Use the mouse wheel to zoom in and out. 

The blue bar below the graph shows the size and location of the zoomed-in section with respect 

to the entire recording. View the exact time and date of any point by moving the cursor over the 

graph while holding down the Ctrl key. 

  

 
1 Files that not have been modified since the file’s opening will have an ‘Original’ status. Any file modification will 
change the file status to ‘MODIFIED’. 
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MacroInterpreter 
To use the macro interpreter program, simply click on File → Open, select the file and click Open. A list 

of the channels in the file will appear on the right window, while file details and file remarks will appear 

in the left window. 

If you would like to examine the file in graphical form, click on View → Graph and follow the prompts. 

Note that you can use the mouse wheel to zoom in and out of the recording as desired. After you have 

finished examining the file, you will need to close the graphic window. 

If you would like a quick statistical summary of the file, click on Spreadsheet → Channel Data to 

Spreadsheet. The spreadsheet tab on the window will be automatically selected, and the spreadsheet 

will be displayed. The name of each channel, its position in the file, and its mean, minimum, maximum 

and range will be displayed. 

Split File 
Split File is a MacroInterpreter feature that allows large data files to be split into smaller data files that 

can be opened in ExpeData. Data files can be split to groupings of cages 1-8 and 9-16 or individual cages. 

Only the raw data file(s) should be split using the Split File option. Splitting files modified by macros or 

previously split using this feature may result in incorrect data analysis. 

To split a data file, open the MacroInterpreter program. Click File → Open and load the raw data file 

that needs to be split. Once the file has loaded, click Tools → Split File into 1-8, 9-16 or Tools → Split File 

to Individual Cages. The file split is complete when Done is printed in the lower left corner of the 

program window. The smaller, split files are saved to the same directory as the original larger raw data 

file. Split the files to individual cage if the cage 1-8, 9-16 files are still too large to open in ExpeData. 

Running a Macro 
1. Open MacroInterpreter. 

2. Load the .exp data file. Click on File → Open, select the raw data file and click Open. 

3. Wait for MacroInterpreter to load the raw data file. 

4. Select the One-click macro you want to apply. Click on Macros →Load Macro Collection, select 

the macro and click Open. The analysis tab will be automatically opened, and the text of the 

macro will be displayed in the right-hand window. 

5. To run the macro, click Run. A text window will appear that will display all of the remarks in the 

macro text. Most macros are abundantly annotated with remarks, which always begin with an 

apostrophe. Each remark is displayed as it is encountered. 

6. Wait for the data analysis to be completed. When the macro is completed, the text window will 

disappear, and the note Completed will appear in the bottom left of the program window. 

7. View the data. After completion, a .xml file is generated in the same .exp raw data directory. 

Open the .xml via Excel. 

In general, MacroInterpreter will be used with comprehensive, one-click macros. In this case, the macro 

number in the loaded macro collection will be one. If more specialized macros are used, there may be 

several macro numbers available.  

In the case of one-click macros, the file that is automatically produced is in the .xml format. These files 

can be loaded into practically any spreadsheet program, including open versions. Writing in this format 
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avoids having to deal with the necessity of having Microsoft Excel loaded on the computer, and also 

avoids bugs in the Microsoft.net framework that can intermittently occur when transferring data directly 

to Excel. If you are using Excel, simply load the XML file (usually, these files are associated with Excel so 

you can simply double-click on the file to load it). After doing so, it is recommended to save the 

spreadsheet as a .xlsx file, which is approximately 10 times more compact. At that point you can delete 

the XML file if you wish. 

Note that in order to create a useful link between the data file and the macro that created the 

spreadsheet, the default name for the spreadsheet is created by appending the macro name to the 

filename. The actual macro number that was called (usually macro 1 for a 1-click macro collection) is 

appended to this as well, preceded by an underline. For example, if the original data file is named 

“Test_Run”, and it is analyzed using One-Click Macro V2.38-slice1hr, then the XML file generated by the 

macro will have the file name of Test_Run_macro_One-Click Macro-slice1hr.mac_1. 
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One-Click Macro Analyses 
The intention of the one-click macros is to provide all of the commonly used analytical outputs without 

requiring the user to sequentially run a variety of macros in a collection. It may contain more data than 

most users will typically use, but it is hoped that user curiosity will lead to useful information being 

discovered in the less frequently used options. 

A minor edit to the one-click macro may be required for the circadian analysis. If a light level channel 

does not exist in the data file, you may need to edit the cycle information. To do so, load the macro 

collection into a text editor (Notepad will do; Notepad++ is a more advanced open source version that is 

highly recommended). Search for the command “assign circadian_markers” and edit the diurnal hours 

duration to the correct number of hours (usually 12), and the diurnal StartTime, using a standard 24-

hour format (hh:mm:ss). Save the macro file under a different name that will identify the circadian 

timing used. 

Various analyses will appear in the spreadsheet, separated by worksheets that are accessed in the tabs 

at the bottom of the program window. These are:  

• Time Series 

• Macro 13 

• Circadian 

• Food Intake Pattern 

• Wheel Pattern 

• Time Budget percent 

• Locomotion Budget percent 

• Locomotion Budget in meters per hour 

• Behavior Transitions 

• QC checks 

• Metadata 

QC checks and Metadata are two housekeeping worksheets. QC Checks performs some basic checks on 

data integrity. This can pick up many potential issues and should always be checked. Metadata 

summarizes the important details about the file, including its location, the setup file that was used to 

specify recording parameters, the date and time the recording stopped, the number of samples, the 

version of the program acquiring the data, and a wide variety of calibration information for all of the 

important sensors and transducers in the system. If specific details concerning the animals are entered 

into the remarks, they can be accessed by the macros (for example, this happens in the circadian data 

worksheet). In addition, at the bottom of the worksheet, it will show the macro version that was used to 

create the spreadsheet, and the exact folder in which the macro version is located. The rest of the data 

analyses will be described in more detail in the following sections.  
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Time Series and Macro 13 
The Time Series analysis outputs commonly used metrics, with the cage number denoted by the animal 

column. Thus, in a statistics program, it is straightforward to isolate individual mice or compare groups 

of mice by using the animal datum to identify them. Macro 13 outputs the same data as Time Series, but 

with a separate column for each animal. In this case, the animal number is denoted by a numeric suffix 

preceded by an underline for each column header. In both worksheets, the units for VO2 and VCO2 are 

mL/minute, units for EE are kcal/hour, units for VH2O are grams /hour, units for intake and body mass 

are grams, units for distance are meters, and units for speed are meters/second. 

Suffix Definitions 
_M This is the mean value of the data obtained during the time that metabolic data were obtained from 

the cage. Typically, in Promethion systems, the metabolic data are obtained in 30 seconds for each cage. 

By default, a baseline (which measures the incurrent values of oxygen, carbon dioxide and water vapor) 

is taken every four cages. Each analyzer chain in a Promethion system is assigned eight cages (typical 

Promethion systems contain one, two, or three analyzer chains). Thus, individual samples are taken 

from each cage every five minutes, irrespective of the size of the complete system. (This can be reduced 

every 2.5 minutes with some careful tuning of the system and can also be reduced by assigning fewer 

than eight cages to each analyzer.) Data on VO2, VCO2, VH2O, energy expenditure (kcal/hr) and RQ are 

best obtained at the moment of cage sampling. Certain other forms of data which are calculated in 

cumulative fashion, such as food and water intake and body mass, pedestrian meters run and wheel 

meters run etc., can also be measured during this time and will also be given the _M suffix. But for 

certain other types of data, it does not make sense to examine only the data during the time when the 

gas sample from the cage was being analyzed. 

_R This is the range of the data across an entire cycle of measurement (R=Range), in other words, from 

the end of the previous time the cage was selected until the end of the current cage measurement. By 

default, in Promethion systems, this is every five minutes. If we are interested (for example) in the 

distance a mouse traveled by foot during each measurement interval, it would make no sense to look at 

the data range within only the period of metabolic measurement, which is typically just 30 seconds long. 

Rather, we are interested instead in the total distance the mouse traveled since the cage was last 

selected. 

_MNZ This is the mean of the data across the entire cycle of measurement (M=Mean) but with zero 

values excluded from the mean calculation (NZ=No Zeros). This is useful for extracting actual pedestrian 

mall wheel running speeds. For much of the time, the mouse will not be moving or running at all and 

thus the speed during those times will register as zero. This will tend to drag down the mean speeds by 

an unpredictable amount, depending on the amount of time for which the mouse was not moving. To 

avoid this, excluding zeros from the calculation gives a more faithful data extraction that reflects the 

actual speeds at which the mouse typically moved. Recall that the total distance moved is available as 

another column, so you do not lose information on the actual distance the mouse moved. 

_X Denotes the cage number for animal X 
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Column Prefix & Title Definitions 
AllMeters Sum of all distances traveled within the beam break system, not including any distance run on 

the wheel (WheelMeters), in meters (m). This includes fine movement (such as grooming and 

scratching) as well as direct locomotion. AllMeters are always greater than PedMeters. To get an index 

of fine activity, subtract PedMeters from AllMeters. 

Animal Cage number. 

BodyMass Mean body mass of animal, in grams (g). 

BodyTemp Mean body temperature of animal in cage X, in degrees Celsius (°C). Telemetry is required to 

acquire this data. 

FoodInA Mass of food consumed by animal during the cycle, in grams (g). 

FoodInB Mass of food consumed by animal during the cycle, in grams (g). This data will only exist if there 

is a second food option present. 

HeartAmp Heart rate amplitude, in beats per minute (BPM). Telemetry is required to acquire this data. 

HeartRate Heart rate, in beats per minute (BPM). Telemetry is required to acquire this data. 

kcal_hr Mean energy expenditure (EE) of animal, in kilocalorie per hour (kcal/hr). EE is calculated using 

the Weir equation.2 

PedMeters Sum of all directed ambulatory locomotion within the beam break system, excluding all 

wheel locomotion, in meters (m). For defining directed locomotion, the macros use a speed cut off of 1 

cm/s. If the animals travel at that speed or faster, it is considered to be directed locomotion. 

PedSpeed Mean directed ambulatory locomotion speed, in meters per second (m/s).  

RER Mean respiratory exchange ratio (RER), VCO2/VO2, unit-less. 

TelAct Summation of activity. The Gross Motor Activity unit of measure is a Count. A Count represents 

the frequency and intensity of the subject’s movement per second. Depending on what sampling output 

is selected, all activity generated per second is stored in a buffer then outputted in a total count output 

at the conclusion of your selected sample size. Telemetry is required to acquire this data. 

TreadAngle The angle of the treadmill in degrees. 

TreadSpeed The speed of treadmill given in meters per minute (m/min). 

TreadShocks The number of times the animal was shocked while on the treadmill. 

VCO2 Rate of carbon dioxide emission (VCO2), in milliliters per minute (ml/min). 

VH2O Rate of water vapor loss (VH2O), in milliliters per minute (ml/min). 

VO2 Rate of oxygen consumption (VO2), in milliliters per minute (ml/min). 

 
2 Weir (1949): New methods for calculating metabolic rate with special reference to protein metabolism. J Physiol. 109:1–9. 
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WaterInA Mass of water consumed by animal during the cycle, in grams (g). 

WheelMeters The number of meters (m) run on the wheel, not including any ordinary pedestrian 

locomotion around the cage. 

WheelSpeed Mean wheel speed when animal is running on wheel, in meters per second (m/s). 

XBreak Number of X-axis beam breaks. 

YBreak Number of Y-axis beam breaks. 

ZBreak Number of Z-axis beam breaks. 
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Circadian 
The extracted data from the Circadian analysis are separated by circadian cycle, denoted in the Cycle 

column (0 = nocturnal, one = diurnal). If data on the age, genotype, ID, sex or initial mass of the animal 

are recorded in the file remarks, these are extracted into the appropriate columns. All column names 

refer to the measured variable across the entire duration of the circadian cycle. Note that this analysis 

includes food intake pattern analysis. 

Column Prefix & Title Definitions  
A_EE_15 Mean energy expenditure (EE) during the 15 minutes with highest EE, in kilocalorie per hour 

(kcal/hr). EE is calculated using the Weir equation.3  

A_RER_15 Mean respiratory exchange ratio (RER) during the 15 minutes with highest energy 

expenditure (EE), unit-less. 

AccessA_pct Sum of the time that the animal has unrestricted access to the food, as a percentage of 

cycle (%). 

Adur_hrs Sum of animal’s time active during the highest activity 15-minute period, in hours. 

AllMeters Sum of all distances traveled within the beam break system, not including any distance run on 

the wheel (WheelMeters), in meters (m). This includes fine movement (such as grooming and 

scratching) as well as direct locomotion. AllMeters are always greater than PedMeters. To get an index 

of fine activity, subtract PedMeters from AllMeters. 

Animal Cage number. 

Age_months Animal’s age, in months. Extracted from user-entered information in Animal Data Entry. 

Avg_EE Mean energy expenditure (EE), in kilocalorie per hour (kcal/hr). EE is calculated using the Weir 

equation.3 

Avg_RER Mean respiratory exchange ratio (RER), unit-less. 

Avg_VCO2 Mean rate of carbon dioxide emission (VCO2), in milliliters per minute (ml/min). 

Avg_VH2O Mean rate of water vapor loss (VH2O), in milliliters per minute (ml/min). 

Avg_VO2 Mean rate of oxygen consumption (VO2), in milliliters per minute (ml/min). 

BodyMass_g Mean body mass of animal, in grams (g). 

BodyMass_SD Standard deviation of body mass measurement, in grams (g). 

BP_kPa Mean barometric pressure, in kilopascal (kPa). 

Cycle Circadian cycle state. 1 is nocturnal, 0 is diurnal. 

Cycle_Hrs Length of cycle, in hours. 

Day Number of days from the start of the run. 

 
3 Weir (1949): New methods for calculating metabolic rate with special reference to protein metabolism. J Physiol. 109:1–9. 
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EndTime Cycle end time. 

Genotype Animal’s genotype. Extracted from user-entered information in Animal Data Entry. 

Id_code Animal’s identification code. Extracted from user-entered information in Animal Data Entry. 

InitMass_g Animal’s initial mass, in grams (g). Extracted from user-entered information in Animal Data 

Entry. 

InterUptakeA_min Mean food inter-intake event duration, in minutes. This data is from the first food 

hopper present. 

InterUptakeB_min Mean food inter-intake event duration, in minutes. This data will only exist if there is 

a second food hopper present. 

InterUptakeW_min Mean water inter-intake event duration, in minutes. 

PedMeters Sum of all directed ambulatory locomotion within the beam break system, excluding all 

wheel locomotion, in meters (m). For defining directed locomotion, the macros use a speed cut off of 1 

cm/s. If the animals travel at that speed or faster, it is considered to be directed locomotion. 

PedSpeed Mean directed ambulatory locomotion speed, in meters per second (m/s). 

QA_EE_15 Mean energy expenditure (EE) during the highest EE 15-minute “quiet” period, in kilocalorie 

per hour (kcal/hr). EE is calculated using the Weir equation.4 

QA_RER_15 Mean respiratory exchange ratio (RER) during the highest energy expenditure 15-minute 

“quiet” period, unit-less. “Quiet” is defined as time in which the animal was not engaged in eating, 

drinking, grooming, nor locomotion. 

QR_EE_30 Mean energy expenditure (EE) during the lowest activity 30-minute period, in kilocalorie per 

hour (kcal/hr). This would be the approximation of resting metabolic rate because it is for the period 

when the animal “rested” the longest. EE is calculated using the Weir equation. 4 

QR_RER_30 Mean respiratory exchange ratio (RER) during the lowest activity 30-minute period, unit-

less. 

R_EE_30 Mean energy expenditure (EE) during the lowest EE 30-minute period, in kilocalorie per hour 

(kcal/hr). EE is calculated using the Weir equation. 4 

R_RER_30 Mean respiratory exchange ratio (RER) during the lowest energy expenditure (EE) 30-minute 

period, unit-less. 

Rdur_hrs Sum of animal’s time resting during the lowest activity 30-minute period, which is defined as 

no ambulatory nor wheel locomotion, in hours. 

Run_pct Sum of animal’s time spent running on wheel, as a percentage of cycle (%). 

Sex Animal’s sex. Extracted from user-entered information in Animal Data Entry. 

 
4 Weir (1949): New methods for calculating metabolic rate with special reference to protein metabolism. J Physiol. 109:1–9. 
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Sleep_hrs Sum of animal’s sleep, in hours. The animal is considered sleeping when the animal has been 

“quiet” for more than 40 seconds.5 Animal’s “quiet” time is defined as time in which the animal was not 

engaged in eating, drinking, grooming, nor locomotion. 

Sleep_pct Sum of animal’s sleep, as a percentage of cycle (%). The animal is considered sleeping when 

the animal has been “quiet” for more than 40 seconds.5 Animal’s “quiet” time is defined as time in 

which the animal was not engaged in eating, drinking, grooming, nor locomotion. 

StartDate Cycle start date. 

Still_pct Animal’s “quiet” time, which is the time at which the animal was not engaged in eating, 

drinking, grooming, nor locomotion, as a percentage of cycle (%). Still_pct is always greater than 

Sleep_pct. Subtract Sleep_pct from Still_pct to get the time the animal is “quiet,” but not asleep. 

StartTime Cycle start time. 

Tot_EE Sum of energy expenditure (EE) in kilocalories. EE is calculated using the Weir equation.6  

UptakeA_g Mean mass of food consumed during an intake event, in grams (g). 

UptakeA_min Mean food intake event duration, in minutes. 

UptakeA_N Number of food intake events. 

UptakeA_Sum Sum of all food consumed, in grams (g). 

UptakeB_g Mean mass of food consumed during an intake event, in grams (g). This data will only exist if 

there is a second food option present. 

UptakeB_min Mean food intake event duration, in minutes. This data will only exist if there is a second 

food option present. 

UptakeB_N Number of food intake events. This data will only exist if there is a second food option 

present. 

UptakeB_sum Sum of all food consumed, in grams (g). This data will only exist if there is a second food 

option present. 

UptakeW_g Mean mass of water consumed during an intake event, in grams (g). 

UptakeW_min Mean water intake event duration, in minutes. 

UptakeW_N Number of water intake events. 

UptakeW_Sum Sum of all water consumed, in grams (g). 

Walk_pct Sum of animal’s time spent in ambulatory locomotion, as a percentage of cycle (%). 

 
5 Pack, A, Galante, R, Maislin, G et al. (2007): Novel method for high-throughput phenotyping of sleep in mice. Physiological Genomics 28, 232-

238. 
6 Weir (1949): New methods for calculating metabolic rate with special reference to protein metabolism. J Physiol. 109:1–9. 
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WheelMeters The number of meters (m) run on the wheel, not including any ordinary pedestrian 

locomotion around the cage. 

WheelSpeed Mean wheel speed when animal is running on wheel, in meters per second (m/s). 

XBreaks Number of X-axis beam breaks. 

YBreaks Number of Y-axis beam breaks. 

ZBreaks Number of Z-axis beam breaks. 
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Food Intake Pattern 
The Food Intake Pattern Analysis will output detailed information for every intake event for each animal 

during the entire experiment. An intake event is detected by scanning the food hopper mass channel for 

the high standard deviation in the measured mass caused by the animal interacting with the hopper. 

Internally, the algorithm creates a standard deviation vector of the mass channel, with a sliding window 

size that is set in the “SD slide window" box. When the standard deviation rises above the value in the 

"Standard deviation threshold for intake" box, the algorithm suspects that a feeding event is taking 

place. If the threshold value is set too low, the intrinsic noise in the measurements will continually give 

false triggers. In general, the minimum standard deviation threshold is set to 0.02 g for water intake, 

and 0.05 g for food intake. This difference is because water intake is a kinder, gentler process than food 

intake, resulting in a smaller standard deviation signal. The different parameters that are used to detect 

food and water intake events are listed in Table 1 below.  

Table 1: Food and Water Intake Parameters 
 

 Minimum 
Intake 
Duration 
(Seconds) 

Maximum 
Pause 
Seconds 

Standard 
Deviation 
Threshold 

Maximum 
Probability 

Minimum 
Uptake 
Mass (g) 

Maximum 
Uptake 
Mass (g)  

       

       

Food 30 150 .05 .05 0 1 

Water 10 30 .02 .05 0 1 

 

After a suspected intake event is detected, the algorithm waits until the standard deviation drops below 

the threshold. Of course, momentary pauses in food intake may occur, and it is important that the 

algorithm is not fooled into thinking that the entire intake event is over. As a result, a value for the 

"maximum inter-intake pause duration" is obtained from the appropriate box in the dialog. This ensures 

that brief pauses in intakes are not considered to be the end of an intake event. By default, the 

maximum inter-intake pause duration is set at 300 seconds. It can be set lower if detailed intake pattern 

analyses are needed, which require more granular data. 

Similarly, the value in the "Minimum intake duration" box determines the minimum duration of an 

intake event. This is particularly useful for water intake events, which generally last about 5-30 seconds. 

Thus, the minimum intake duration should be set to 10 seconds for water intake. For food intake, which 

generally takes longer, 30 seconds is usually appropriate. Note that with water intake analysis, dripping 

from the sipper tube (which can take place during sudden temperature changes) causes a sharp, 

momentary drop in the water hopper mass that will be rejected as a valid reading. 

When an intake event is detected, and it lasts for at least as long as the minimum event duration (in 

seconds), and is separated from the previous intake event by at least the maximum inter-intake pause 

duration, the algorithm marks the beginning and the end of the intake event by finding at least six 

consecutive samples of the standard deviation vector that are below the standard deviation threshold. 

The search is made downstream (in the past) in the case of intake initiation, and upstream in the case of 

intake termination. 
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The algorithm next determines the mean and standard deviation of the most level section of eight 

consecutive samples 60 seconds prior to, and 60 seconds after, the intake event. The two means and 

standard deviations are then plugged into a two-sample, equal N Student’s t-test, and the resulting T 

statistic is evaluated for the probability that the two means are equal. By default, a valid intake event 

should have a probability of less than or equal to 0.05. This probability can be set in the "maximum 

probability for uptake” event box. If an intake event evaluates to a probability above the maximum, it is 

ignored. 

Because mice will occasionally drop pieces of bedding and other objects into the food hopper, which will 

result in a false negative mass reading, the system by default ignores intakes below the value in the " 

signal intakes less than this mass " box. Such readings can also be caused by freak interactions between 

the mouse and the hopper. Likewise, such interactions can cause spurious positive intake events that 

can be quite large, especially when food access is unblocked owing to the mechanical interaction 

between the food access control door and the food hopper. For this reason, intakes above the value in 

the " signal intakes greater than this mass" box are ignored. 

Optionally, "meals" can be analyzed in the case of intake pattern analysis. Meals are regarded as groups 

of intake events separated by longer pauses than individual intake events; the default maximum pause 

duration is set in the " maximum pause duration within meal " box. This setting is only valid for intake 

pattern analysis. 

If intake processing occurs without a selected data section (in other words, for the entire duration of the 

recording), the default mode of action is to calculate cumulative intake, and the cumulative total intake 

replaces the original data. If a data section is selected, detailed intake pattern analysis occurs by default. 

For example, the circadian macro selects day and night sections of the intake channels and performs 

detailed intake pattern analysis on them, whereas the standard "macro 13" output first transforms the 

intake channels into cumulative totals, and then calculates the range for each output point. 

Detailed intake pattern analysis can optionally be saved to the clipboard or to a file in the folder of the 

original data file.  

It is easy to create macros that cycle through different values of the key parameters by using a for/next 

loop. If the resulting values are written to a spreadsheet, it is possible to visualize the effect of the 

parameters on (for example) total intake amounts. 
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Column Prefix & Title Definitions 
Accum_g The total cumulative amount of food eaten, in grams (g). 

Cage Animal number 

EndDate The date at which the current intake event ended 

EndTime The time at which the current intake event ended 

Event Food intake event number 

In_g The amount of food eaten during the current intake event, in grams (g). 

In_g_min The intake rate during the current intake event, in grams per minute (g/min). 

In_min The duration of the current intake event, in minutes. 

InF_g_min The amount of force that the mouse exerted on the hopper, obtained by integrating under 

the mass profile during the intake event, in grams per minute (g/min). 

InterIn_min The inter-intake interval immediately prior to the current intake event, in minutes. For the 

1st intake event, this inter-intake interval is unknown, thus it is indicated as 0. 

Prob The probability that the food intake event was the result of chance (“false positive.”) 

StartDate The date at which the current intake event started 

StartTime The time at which the current intake event started 

Stud_t The Student’s t-statistic calculated from the mass and standard deviation of the mass of the 

hopper immediately prior to, and immediately after the end of the feeding event. The t statistic is then 

used to calculate the probability, given the actual mass measurement precision found in the file, that 

the food intake event was the result of chance. By default, this probability is set to < 0.05. The vast 

majority of intake events are below .001 probability, which is indicated by 0. 
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Wheel Pattern  
Similar to the food intake pattern analysis, this analysis will output detailed information for each wheel 

running event during the entire experiment for each animal.  

As you know, mice do not run continuously on the running wheel. They will occasionally stop for a 

second or two or three, and then continue running again. The wheel pattern analysis assumes that if a 

pause (i.e. the mouse being still) lasts for longer than five seconds, any subsequent running should be 

counted as a separate running event. The value can be changed by modifying the “max_pause” 

parameter in the macro.  

This means that in some running bouts, the mouse may have paused for a few seconds, with no pause 

lasting longer than five seconds in the case of the current macro parameters. The "still" column shows 

the total number of seconds during which the mouse did not run on the wheel during the running bout.  

Because the actual duration of wheel-running can be different from the duration of the complete 

running bout (the format excludes the still periods, while the latter includes them), the running speed of 

the mouse on the wheel is best measured by the distance it runs divided by the actual duration of wheel 

running, not including the still periods. This is the column RunMeters_sec. However, if for some reason 

you want to know the average speed of the running during the entire wheel running bout including the 

still periods, this is available in the column AvgMeters_sec. Thus, RunMeters_sec will always be higher 

than AvgMeters_sec unless the mouse had absolutely no pauses during the running bout.  

Column Prefix and Title Definitions 
Animal Cage number. 

AvgMeters_sec The average running speed during the entire wheel running event measured by the total 

distance run divided by the total time of the event including the still periods, in meters per second (m/s). 

Dur_secs Duration of the current wheel running event, in seconds. 

EndTime The time at which the current wheel running event ended 

Joules_area_hrs Used to estimate net cost of transport by regressing meters run per running bout (x) 

against Joules of net energy expended during each bout. (Joules is labeled Joules_area_hr because it is 

obtained by integrating the area under the curve of Joules per hour against time in hours). The slope of 

the line is the NCOT in net Joules per meter. 

PostRun_secs The time interval between when the current running wheel event ends and the next 

wheel running event starts, in seconds.  

PrevRun_secs The time interval between when the previous running wheel event ends and the current 

wheel running event starts, in seconds. For the 1st event, this interval is unknown, thus it is indicated as 

0. 

RunMeters_sec The average running speed during the wheel running event measured by the total 

distance run divided by the actual duration of wheel running, not including the still periods, in meters 

per second (m/s).  

Sample The sample number at which the current wheel running event started 
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StartDate The date at which the current wheel running event started 

StartTime The time at which the current wheel running event started 

Still_secs The amount of time during the current running wheel event that the animal paused on the 

wheel and was not running, in seconds. 

WheelMeters The number of meters (m) run on the wheel during the current wheel running event 

Wheel_Revs The number of wheel revolutions for the current running wheel event. 
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Ethoscan 
The Promethion system acquires a uniquely rich stream of data and knows exactly where the animal is, 

and what it is doing, in any given second. Ethoscan is a tool to examine an animal’s behavior and activity 

and generates a list of each successive behavior. The list of currently available behaviors for analysis are 

defined below. 

Behaviors can be analyzed by monitoring the animal’s activity and interactions with cage sensors. For 

example, if the mass measured by the body mass sensor suddenly increases, it is known that the animal 

has entered the body mass habitat. If the variance of the food intake monitor measurements suddenly 

increase, it is known that the animal is interacting with the food hopper. From these interactions, and 

sometimes even from the lack of such interactions, a detailed sequence of the behaviors exhibited by 

the experimental animal in each cage can be obtained. If the animal is not actually interacting with any 

of the internal cage sensors— the running wheel, food hopper, water dispenser, or body mass habitat— 

then the animal is considered to be “lounging.” Ethoscan analysis distinguishes between a short lounge 

duration, a lounge between 5 and 60 seconds, and a long lounge, which is simply a lounge lasting longer 

than a short lounge. 

Behavior Definitions 
EfodA Eating food from food hopper A, as evidenced by a significant difference in the food hopper mass 

from before to after the eating event.7 

TfodA Touching food hopper A without actually removing a significant amount of food.7 

DWatr Drinking water, as evidenced by a significant difference in the water dispenser mass from before 

to after the drinking event.7 

TWatr Touching the water dispenser without actually removing a significant amount of water.7 

Wheel Completing at least one revolution of the running wheel. 

IHome Entering the body mass habitat for a long enough time to obtain a stable mass reading. 

THome Touching the body mass habitat or entering very briefly, in such a way that its mass reading 

disturbed but a stable mass is not available. 

LLnge Long lounge: wandering around the cage, without interacting with the food or water mass 

monitors, the body mass monitor, or the wheel, for more than 60 seconds. 

SLnge Short lounge: wandering around the cage, without interacting with the food or water mass 

monitors, the body mass monitor, or the wheel, for 5-60 seconds. 

EfodB Eating food from food hopper B, as evidenced by a significant difference in the food hopper mass 

from before to after the eating event.7 This behavior will only appear in the Ethoscan analysis if a second 

food hopper is present. 

TfodB Touching food hopper B without actually removing a significant amount of food.7 This behavior 

will only appear in the Ethoscan analysis if a second food hopper is present. 

 
7 Events are evaluated for statistical significance with a T-test of a 20s baseline sample before vs. after the event. 
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The behavior list is available across any selected section of the recording for each animal. In 

addition to the behavior code, each entry in the list contains the duration of the activity, the exact 

start and stop calendar times, the mean position of the animal in XY coordinates, and a specific 

quantity associated with that activity. For example, in the case of a long lounge or short lounge, the 

distance moved is the specific quantity; in the case of food intake, the amount of food eaten; in the 

case of body mass habitat entry, the body mass of the animal; and so on. 

Table 2: Example Ethoscan behavior list. 
 

 

Sample 

Start Start End Duration 

Activity Amount 

Rear X Y S 

Date Time Time (sec) (%) (cm) (cm) (cm) 

            

1 11/8/2013 12:19:30 13:16:25 3416 llnge 22 5.3 8.3 19.7 22  

3417 11/8/2013 13:16:26 13:42:17 1552 ihome 22.207 0 10.8 9 0  

4969 11/8/2013 13:42:18 13:42:48 31 slnge 21 32.3 6.7 20 21  

5000 11/8/2013 13:42:49 13:44:10 82 efoda 0.038 46.3 10.2 20.9 1  

5082 11/8/2013 13:44:11 13:44:52 42 slnge 2 7.1 10.3 20 2  

5124 11/8/2013 13:44:53 13:48:19 207 efoda 0.044 44 8.8 21.4 52  

5331 11/8/2013 13:48:20 13:48:25 6 slnge 3 16.7 7.5 24.6 3  

5337 11/8/2013 13:48:26 15:16:44 5299 ihome 22.139 0 7.5 22.8 0  

10636 11/8/2013 15:16:45 15:17:22 38 slnge 14 31.6 8.1 24.4 14  

10674 11/8/2013 15:17:23 15:56:38 2356 ihome 21.711 0 8.5 21 0  

 
 

Amount is centimeters (cm) for slnge and llnge, revolutions for wheel, grams (g) for efoda, efodb, and ihome, and 

mililiters (mL) for dwatr. Rear (%) is the percentage of the behavior duration spent rearing, which is determined from 

the Z-axis beambreak array. X and Y are the average X and Y beambreak array position during the behavior, 

respectively. S is the total distance travelled during the behavior.  

A lot of information can be derived from the behavior list. The following sections provide example 

behavioral analyses that are already built into Ethoscan. These analyses give a great deal of 

information that can be subjected to standard statistical analyses, providing researchers the ability 

to investigate and quantify differences between control and experimental groups of animals 

(assuming there is a difference). Treatment effects for injections or cannular transfusions can also 

be quantified.  
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Time Budget 
A complete time budget is available for each animal. Each activity is shown in terms of the percentage of 

the animal’s total time engaged in this activity during the selected cycle. 

 

Figure 1: An animal's time budget 

  

Time Budget

EfodA TfodA DWatr TWatr Wheel IHome

THome LLnge SLnge EfodB TfodB
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Locomotion Budget 
A locomotion budget is available for each animal. This shows the percentage of overall total distance 

traveled during each of the behaviors recognized by the system. Absolute distances traveled (in meters) 

are also available for all behaviors. 

 

 

Figure 2: An animal’s non-wheel and with-wheel locomotion budgets. 

 

 

Non-wheel Locomotion Budget

Animal EfodA TfodA DWatr TWatr IHome THome LLnge SLnge

With-wheel Locomotion Budget

Animal EfodA TfodA DWatr TWatr Wheel IHome THome LLnge SLnge
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Behavior Transition Probability Matrix 
A behavior transition probability matrix is available for each animal. Although the term may sound a bit 

daunting, the concept is simple. Imagine that the animal is eating food. That is only one of several 

behaviors recognized by the system. When the animal stops eating, what will its next behavior be? The 

behavior transition probability matrix allows you to determine that easily. For example, 30% of the time, 

after eating the animal may drink; it may go directly to the running wheel only 2% of the time, to its 

body mass habitat 40% of the time, and so on. For every behavior, the percentage probability of each 

possible next behavior is calculated and displayed. In essence, the behavior transition probability matrix 

tells the researcher, as far as it can, how the mind of the experimental animal works. Moreover, it is 

objective. It can also be subjected to some interesting and powerful statistical analyses, such as 

hierarchical object clustering, which in turn allows a dendrogram of animals grouped by the relatedness 

of their behaviors to be displayed. 

Table 3: Example Ethoscan behavior transition probability matrix. 
 

 

efoda tfoda dwatr twatr wheel ihome thome llnge slnge efodb tfodb 

Sum 

 

(%)             

             

efoda 0 0 30.05 0 2.12 40.03 0 12.56 15.24 0 0 100 

tfoda 0 0 0 0 7.23 0 0 14.46 78.31 0 0 100 

twatr 4.55 0 0 0 0 9.09 13.64 4.55 68.18 0 0 100 

wheel 0 1.35 0 0 0 0 1.62 12.94 84.1 0 0 100 

ihome 0 0 0 0.67 2.68 0 0 17.45 79.19 0 0 100 

thome 0 0 1.75 1.75 5.26 0 0 19.3 71.93 0 0 100 

llnge 16.46 12.66 7.59 2.53 25.95 19.62 15.19 0 0 0 0 100 

slnge 13.28 7.86 7.86 2.03 42.55 15.58 10.84 0 0 0 0 100 

 

The probability matrix is viewed left to right. The first column shows the initial behaviors and the other columns along 

a given row show the percent probability of the first subsequent behavior.  

 

 

 

 


